Как установить и использовать OpenVPN?

Я надеялась на мой настольный компьютер, который в настоящее время работает в настольную версию Ubuntu, и вместо того, чтобы запустить сервер Ubuntu. После того, как сервер настроен и работает правильно, я должен быть в состоянии следовать этот учебник http://madisonlinux.org/InstallingOpenVPNOnUbuntu10.04, который я считаю, позволяет мне соединить надежно с моего окна на основе ноутбука. Так что если кто-то может сказать мне, какой сервер надо установить, и как установить его, это было бы круто.

Я предполагаю, есть уже учебник, на этих форумах уже говорят, как это делать, но, к сожалению, после попытки 3 разных поисков я не смог найти его. Так что не стесняйтесь, чтобы добавить ссылку на эту тему, который мне подсказывает, как занять мое рабочем столе и сделать его сервер Ubuntu.

+318
noah sofly 22 авг. 2017 г., 23:15:28
15 ответов

есть инструмент, который позволяет прокручивать с помощью перетаскивания мыши с нажатой Правой Кнопкой. Я использую приложение под названием "MouseImp" на Windows много лет назад. Средство оказалось очень удобно, так как вы были в состоянии прокрутить гораздо быстрее, чем с мышкой-колесо, например, на больших страницах. Кроме того, вы сумели прокрутки и горизонтальной.

Все это было возможно только держа правую кнопку мыши-кнопка нажимается в любом месте на окне и перетащить указатель вверх, вниз и т. д.

Программное обеспечение стало открытым исходным кодом несколько лет назад, но ЕМНИП там не было порта под Linux.

Лучшие, YSN

+967
Root125 03 февр. '09 в 4:24

От человека чмод

команду chmod никогда не изменяет права на символьные ссылки, чмод системный вызов не может изменить их разрешения. Это не проблема, так как права символьных ссылок никогда не используются. Однако, для каждой символьной ссылки, перечисленные в командной строке chmod изменяет права на указанное файл. При этом chmod игнорирует символьные ссылки, встречающиеся во время рекурсивной обработки каталогов.

Регистрация права вместо: Лл /usr/доли/программное обеспечение-центра/программное обеспечение-центра.

+937
kim jong real 20 мар. 2018 г., 12:34:22

Вам нужно выяснить, почему ваша система не может определить разрешение монитора правильно, скорее всего из-за драйверов дисплея.

В любом случае, xrndr решение включает несколько шагов - посмотреть, если вы пропустили любой.

  • Рассчитать режим линии

$ вариатор 1920 1280

  • Создать в линии режим сверху

$ xrandr поближе --использованием newmode "1920x1280_60.00" 206.25 1920 2056 2256 2592 1280 1283 1293 1327 -hsync +дней назад

или

$ newmodecmd=$(вариатор 1280 1024 | грэп "режим" | СЭД -не с/режим/расширения xrandr --использованием newmode/п)

$ newmodecmd

  • Добавить режим на дисплее

$расширения xrandr --addmode входы vga1 "1920x1280_60.00"

  • Активировать режим.

$ расширения xrandr --выход входы vga1 --режим "1920x1280_60.00"

+907
Khrob 20 апр. 2012 г., 17:36:30

(Примечание: все мои ссылки на пункты меню и заголовки окон может быть нарушена. У меня нет английской версии Ubuntu, поэтому я просто перевожу из моего собственного пользовательского интерфейса. Я надеюсь, что это поможет вам в любом случае найти элементы Проппер. Кто-нибудь с англоязычным интерфейсом могут редактировать мой пост с именами Проппер :-) ).

Вы, кажется, установлен третий репозиторий партии, что больше не отвечает. На самом деле, учитывая его имя, он больше похож на "образец ППА адрес", чем реальная вещь... Вы помните, что при добавлении внешнего программного обеспечения некоторые время назад (скажем: 14 дн. назад) ?

Вот некоторые идеи о том, что делать с ним:

1) Вы можете отключить его из списка источников, устранить ошибку и обновить все остальное.

Перейдите в Система->администрирование->источники приложений, затем откройте "другое программное обеспечение" на вкладке. Вы должны увидеть список внешних репозиториев, и той, что указана в вашей ошибке (http://ppa.launchpad.net/user/ppa-name/ubuntu/) должны быть там.

Просто снимите флажок рядом с ним, или даже удалить его из списка, затем закройте окно и снова запустить "менеджер обновлений".

2) Если ППА действительно надо работать и вы установили все через него, удалением его от источников разорвать связь этого программного обеспечения в исходное хранилище, значит, она не будет обновляться больше. Может быть, вы действительно не заботятся, а потом все нормально, но если вы хотите знать, какие программы это и посмотреть, если вы можете повторно установить его репозитория, следуйте рекомендациям ниже :

Чтобы найти его, вы можете перейти к Синаптикс (система->администрирование->менеджер пакетов Synaptic). В левом нижнем углу, можно выбрать "государство" кнопку, которая показывает, на левый верхний, "местные" установленные компоненты. Все программное обеспечение, которое не привязаны к репозиторию будет показан там (либо установлены .деб, или потому, что связь разорвана, как сказано выше).

Если у вас есть такие "местные" программного обеспечения, то вы можете попробовать, чтобы понять, куда он должен был прийти от. Тогда можно попробовать заново установить репозиторий Проппер за это (как ты сделал в первую очередь). Это действительно зависит от самого программного обеспечения, так что я не могу быть более точным...

Надеюсь, что это помогает...

+794
Paul Bissex 3 нояб. 2013 г., 10:16:45

Для компьютера, ЮИД-это единственный способ идентифицировать пользователя, так как имена-это большое удобство для людей. Большинство дистрибутивов Linux запустить generatiing жидкости для локальных пользователей на 1000, и самый высокий uid равен 65535. В общем, теплоносителя ниже 500 зарезервированы для системной учетной записи, 0, как правило, зарезервированных для пользователя root. Надеюсь, что это помогает.

проверить следующие файлы, вы можете получить обзор вашего счета/пароля,

в /etc/passwd с

/и т. д./тень

+619
Ken Bentubo 15 мая 2010 г., 18:48:10

Я просто пакет установлен на Kubuntu-Desktop и я нашел некоторые действительно хорошие темы онлайн:

Theme http://kubuntu-art.org/content/show.php/Ice+cream++%28QtCurve%2CEmerald%2CChrome 29%?content=151493

http://kubuntu-art.org/content/show.php/Elementary+for+KDE+%28QTCurve+%2B+Emerald%29?content=152404

может кто-нибудь сказать мне, как установить эти темы На (к)Убунту 12.04 ?

Спасибо заранее

+567
Rui Ferreira 4 дек. 2011 г., 18:47:42

Он работал хорошо, когда я купил его. Я думаю, что это было обновление или что-то, что заставило его остановиться. Я не думаю, что микрофон сломан, по крайней мере, надеюсь. Может кто-нибудь помочь?

Пожалуйста? Мне это нужно до завтра. Я работаю над видео.

Я получаю это, когда я проверить терминал для какие USB устройства подключены:

Устройство шины 004 001: с ID 1d6b:0001 Linux и основания 1.1 корневой концентратор 
Устройство автобуса 003 004: код 2525:8912
Устройство автобуса 003 003: ИД 058f:9360 Алькор Micro корп. 8-в-1 кард-ридер
Устройство автобуса 003 002: ИД 056a:00d2 Wacom ко., ООО
Устройство автобуса 003 001: с ID 1d6b:0001 Linux и основания 1.1 корневой концентратор
Устройство автобусных 002 001: с ID 1d6b:0001 Linux и основания 1.1 корневой концентратор
Устройство автобусных 001 001: с ID 1d6b:0002 Linux в основу 2.0 корневой концентратор

Спасибо.

+566
Jay Stiff Tecnocolor 9 мая 2018 г., 22:25:37

Я хотел установить VirtualBox-4.0 (или любой другой версии)

  • Я пошел в Система → администрирование → менеджер пакетов Synaptic

  • Затем я отметил, что VirtualBox-4.0 для установки, но я получаю эту ошибку:

    в VirtualBox-4.0:
     Зависит: libqt4-OpenGL, но он не будет установлен
    

Что я должен делать?

+509
user9898 15 авг. 2017 г., 17:59:07

Обновление безопасности для Kerberos пакетов был выдан 31 июля 2012, чтобы исправить уязвимость. Этот наткнулся на Ubuntu версии цифры от ubuntu0.2 в ubuntu0.3.

Это возможно (но редко), что на некоторое время, libkrb5-Дев/krb5 из-multidev пакеты не были обновлены, и таким образом были старые зависимостей ubuntu0.2 что является причиной вашей проблемы.

В любом случае, похоже, теперь эта проблема устранена:

$ АПТ-кэш показать libkrb5-Дев | грэп зависит
Зависит: файл krb5-multidev (= 1.10+для dfsg~бета1-2ubuntu0.3)
$ АПТ-кэша показывают файла krb5-multidev | грэп зависит Зависит: libkrb5-3 (= 1.10+для dfsg~бета1-2ubuntu0.3), libk5crypto3 (= 1.10+смотрите~бета1-2ubuntu0.3), libgssapi-krb5 из-2 (= 1.10+смотрите~бета1-2ubuntu0.3), libgssrpc4 (= 1.10+смотрите~бета1-2ubuntu0.3), libkadm5srv-mit8 (= 1.10+смотрите~бета1-2ubuntu0.3), libkadm5clnt-mit8 (= 1.10+смотрите~бета1-2ubuntu0.3), comerr-Дэв

Пожалуйста, попробуйте команду sudo apt-получить обновление && судо apt-получить -F устанавливают , чтобы попытаться исправить это. Если это не так, просто удалите libkrb5-Дэв пакет. От имитации удаления на мой Дев систему, оказалось, что чашки и Qt dev пакеты также могут быть удалены (libqt3-МТ-Дэв, libcups2-Dev с). А затем установить libkrb5-Дэв снова.

+410
naiman1720 14 окт. 2013 г., 16:27:26

Попробуйте вот инструкции: https://help.ubuntu.com/community/Webcam/Troubleshooting помог мне с моим Асер V5, то, по крайней мере, с guvcview я знаю, что моя веб-камера поддерживает... Хм, но все-таки черный в Skype. Удачи!

+383
user15868 28 дек. 2016 г., 22:31:13

Есть ли приложения для Ubuntu, которая может преобразовать файлы CHM в Книгу совместимый с Kindle?

+360
RassulKa 27 нояб. 2010 г., 23:54:23

отформатируйте диск с помощью diskutility , и убедитесь, что вы совещался возьмите судовладелец кнопки проверки файловой системы'

+353
Toani 4 июн. 2012 г., 20:20:40

Возможные Дубликаты:
Как отключить х во время загрузки?

Я установил Ubuntu LiveCD с 11.10. Как я могу переключиться из графического режима в консольный режим?

P. S. Я хочу, чтобы моя система начала работать в режиме консоли по умолчанию!

+320
aPerfectMisterMan 24 апр. 2011 г., 23:22:46

Я скачиваю дистрибутив Ubuntu 12.04 с диска LiveCD 11.10, подключен к Интернету через модем к смартфону. (Пожалуйста, не спрашивайте, почему...) я обнаружил, что у меня не хватает места, чтобы загрузить его в Мои загрузки на компакт-диске. Как сделать скачать зайдите на мой микро-SD? (Да, у меня он уже установлен.)

+92
aoguang 5 дек. 2015 г., 7:25:31

debtree

По данным приложения сайт, в debtree пакет содержит пакет"графы зависимостей на стероидах".

Примечание: это также очень полезно при планировании обновления программного обеспечения. Это приложение может построить график зависимостей от пакетов, которые еще не установлены в системе. Это будут читать источники.список файлов (обычно находится в файле/etc/АПТ/источников.список), и он будет выполнить текущий запрос, используя этот список.

На следующей диаграмме показан пример запуска debtree на пакет с помощью dpkg. Вот карта его зависимостей:

Чтобы установить debtree из командной строки(сочетание клавиш Ctrl-Альт-Т) введите команду:

судо apt-получить установку debtree

Использование

  • Создать .файл Dot (ориентированный граф рисунок - увидеть в человеке точка в manpage)

    debtree --с-предполагает <пакет> >нет.точка
    
  • Создать график (ПНГ) от .файл точка

    точка -Т ПНГ-вывода из.из ПНГ.точка
    
  • Создать график (Постскриптум) и просматривать его с помощью окуляра

    debtree <пакет> | дот-ТПС | программа - &
    

Помните, что при запуске этого приложения от больших пакетов (т. е. теперь), изображений может быстро стать громоздким и трудночитаемым.

Обратите внимание, что команды apt-rdepends также может быть использован в аналогичном порядке, но с пылу вывода в графических немного более витиевато, на мой взгляд.

См. также: Убунту debtree странице

+59
Sokol93russ 28 апр. 2013 г., 17:34:42

Показать вопросы с тегом